(Express) PAdES not available anymore, document_packaged event not being triggered anymore

Question:

Dear Signicat,

Without changes from our side, we experience issues with PAdES on dashboard-test.signicat.io since yesterday (15th of May): document_packaged event not being triggered in webhooks, thus PAdES not available anymore when trying to download the files of a completed signature flow (all signers signed, files and attachments are available to download but not in the PAdES format anymore).

See “Completed packages” in the 2 screenshots before, on from 14th (when it worked), one from today where it doesn’t work. You’ll see that the screenshot from 14th has " standard_packaging, pades," while the one from today has only " standard_packaging,"

What to do? Did we miss an update that changed the Signicat behavior or is there an issue with your processing queues or…? The same thing worked until 14th of May, not from 15th.
Thanks in advance.

P.S.
We were about to finalize our integration for production usage, then this came up. Not very encouraging. We’d also like to mention that we didn’t encounter any issue with the Signature API until now, so that’s a plus.

Answer:

Hi Mircea!

Yes, unfortunately there is an issue with a third party service that we use to create the PAdES files. We were able to publish a fix yesterday while we wait for the third party to resolve the issue. Apologies for the inconvenience.

Reply from OP:
It looks like we are getting finally getting some (only some) document_packaged events, but with a few hours delay. We still didn’t get it for the screenshot above from 16th of May, “Completed packages” still missing “pades” as in the screenshot.

This wasn’t the case until yesterday, so what happened at Signicat that suddenly there is this sudden big delay, while it used to send both document_signed and document_packaged at almost the same time, one after another.

We couldn’t see anything on the status page regarding an abnormal queue/document_package delay.

Thanks in advance

Reply from OP:
Looks like the issue appeared in the status page after all, then was fixed.
Seems to be fine now.
Thanks for the prompt fix.